Jump to content



Photo

Internet connection not working on new vps server

internet network

  • Please log in to reply
10 replies to this topic

#1 Khevin

Khevin

    Advanced Member

  • Administrators
  • 235 posts
  • LocationMauritius

Posted 08 August 2014 - 04:48 PM

Hello there,

no internet connection can be fix by updating your vps dns,

Please configure your network settings to the IP addresses 8.8.8.8 and 8.8.4.4 as your DNS servers,

Best Regards,

Undefined.


Undefined/Khevin | Haphost Support Administrator

Grab Your Free VPS And Web Hosting Here!

Follow Us On Facebook Twitter Google+ LinkedIn Youtube


#2 Dark

Dark

    Advanced Member

  • Members
  • PipPipPip
  • 43 posts

Posted 08 August 2014 - 05:37 PM

Otherwise just point your server IP address to the domain as A record



#3 eddynetweb

eddynetweb

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 08 August 2014 - 09:44 PM

Looks like your using a IP from AT&T, unrelated to your VPS. May have been a misconfiguration on creating the instance, or you changed it.

 

Enter your network configuration, located at:

/etc/network/interfaces

and look for something like this, labled venet0:0, changing the XXX.XXX.XXX.XXX IP to the one stated in the control panel.

auto venet0:0
iface venet0:0 inet static
        address XXX.XXX.XXX.XXX
        netmask 255.255.255.255

And change the DNS servers to Level3.

nano /etc/resolv.conf - Change to 4.2.2.1

And, restart networking with service networking restart, restart your VPS, or ifdown venet0:0; ifup venet0:0.



#4 rahoolm

rahoolm

    Newbie

  • Members
  • Pip
  • 6 posts
  • LocationIndia

Posted 09 August 2014 - 11:21 AM

Looks like your using a IP from AT&T, unrelated to your VPS. May have been a misconfiguration on creating the instance, or you changed it.

 

Enter your network configuration, located at:

/etc/network/interfaces

and look for something like this, labled venet0:0, changing the XXX.XXX.XXX.XXX IP to the one stated in the control panel.

auto venet0:0
iface venet0:0 inet static
        address XXX.XXX.XXX.XXX
        netmask 255.255.255.255

And change the DNS servers to Level3.

nano /etc/resolv.conf - Change to 4.2.2.1

And, restart networking with service networking restart, restart your VPS, or ifdown venet0:0; ifup venet0:0.

 

Thanks for replying!

I just added some fake ip to ask query here. :)

I did what you said here but still I am not able to perform

apt-get update

getting below error

Err http://archive.canonical.com saucy InRelease

Err http://security.ubuntu.com saucy-security InRelease

Err http://archive.ubuntu.com saucy InRelease

Err http://security.ubuntu.com saucy-security Release.gpg
  Temporary failure resolving 'security.ubuntu.com'
Err http://archive.canonical.com saucy Release.gpg
  Temporary failure resolving 'archive.canonical.com'
Err http://archive.ubuntu.com saucy-updates InRelease

Err http://archive.ubuntu.com saucy Release.gpg
  Temporary failure resolving 'archive.ubuntu.com'
Err http://archive.ubuntu.com saucy-updates Release.gpg
  Temporary failure resolving 'archive.ubuntu.com'
Reading package lists... Done
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/saucy/InRelease

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/saucy-updates/InRelease

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/saucy-security/InRelease

W: Failed to fetch http://archive.canonical.com/ubuntu/dists/saucy/InRelease

W: Failed to fetch http://archive.canonical.com/ubuntu/dists/saucy/Release.gpg  Temporary failure resolving 'archive.canonical.com'

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/saucy-security/Release.gpg  Temporary failure resolving 'security.ubuntu.com'

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/saucy/Release.gpg  Temporary failure resolving 'archive.ubuntu.com'

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/saucy-updates/Release.gpg  Temporary failure resolving 'archive.ubuntu.com'

W: Some index files failed to download. They have been ignored, or old ones used instead.


~~~ rahoolm

www.webgls.info


#5 rahoolm

rahoolm

    Newbie

  • Members
  • Pip
  • 6 posts
  • LocationIndia

Posted 09 August 2014 - 11:25 AM

Hello there,

no internet connection can be fix by updating your vps dns,

Please configure your network settings to the IP addresses 8.8.8.8 and 8.8.4.4 as your DNS servers,

Best Regards,

Undefined.

 

Could you please let me know what should done to update the DNS servers?

I did change the resolv.conf and added

nameserver 8.8.8.8
nameserver 8.8.4.4
service networking restart

But getting same issue, is there anything like opening some port or bind that should be used?

ufw command doesn't work in the console.

Thanks in advance for your help further!


~~~ rahoolm

www.webgls.info


#6 rahoolm

rahoolm

    Newbie

  • Members
  • Pip
  • 6 posts
  • LocationIndia

Posted 09 August 2014 - 12:52 PM

I did all the things as suggested but none of them worked.

Can anyone please share your first time experiences when you got a new free vps server from haphost?

  1. When you got the server where you able to perform apt-get update or yum -y update or yum install or apt-get install or wget some-url? 
  2. Where you able to perform ping www.google.com?
  3. Have you done any settings to access your ip using http://x.xxx.xxx.xxx ?

 

After reboot, I have noticed that the resolv.conf is changed back to original and contains only below line.

nameserver 8.8.8.8

venet0:0 is always set to static IP with the mentioned public IP in the dashboard.

 

Thanks people for sharing information on this aspect.

 

regards,

rahoolm


~~~ rahoolm

www.webgls.info


#7 milralze

milralze

    Member

  • Members
  • PipPip
  • 27 posts
  • LocationBrazil - São Paulo

Posted 10 August 2014 - 02:05 AM

Have you accepted the upgrade ?
If not, you need to run sudo apt-get update and sudo apt-get upgrade again, and say Y at the end of the process.
 
I'm not sure about the errors you get opening kate with kdesudo. In any case, to edit the sources.list file, you can do it from the terminal.
 
For a later utilisation, here are the steps you could have done :
 
Code:
cat /etc/apt/sources.list
Will list what is in the file. You can copy/paste here for info.
 
Code:
sudo nano /etc/apt/sources.list
Will allow you to edit the file with nano in the terminal (no graphical application, nano is a small text editor). You can edit the file, then save it with ctrl-o (letter o) and exit with ctrl-x.

  • milralze likes this

VPS BY HAPHOST

Servers Counter-Strike 1.6

www.mestreservidores.com.br


#8 sophiane

sophiane

    Member

  • Members
  • PipPip
  • 11 posts

Posted 17 August 2014 - 05:44 PM

hello I'm new how do this manipulation



#9 rahoolm

rahoolm

    Newbie

  • Members
  • Pip
  • 6 posts
  • LocationIndia

Posted 22 August 2014 - 09:33 AM

 

Have you accepted the upgrade ?
If not, you need to run sudo apt-get update and sudo apt-get upgrade again, and say Y at the end of the process.
 
I'm not sure about the errors you get opening kate with kdesudo. In any case, to edit the sources.list file, you can do it from the terminal.
 
For a later utilisation, here are the steps you could have done :
 
Code:
cat /etc/apt/sources.list
Will list what is in the file. You can copy/paste here for info.
 
Code:
sudo nano /etc/apt/sources.list
Will allow you to edit the file with nano in the terminal (no graphical application, nano is a small text editor). You can edit the file, then save it with ctrl-o (letter o) and exit with ctrl-x.

 

 

What do you mean by accepted upgrade?

When I do apt-get update I get connectivity errors.

apt-get upgrade runs fine 

root@webgls:/# apt-get upgrade
Reading package lists... Done
Building dependency tree... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@webgls:/# cat /etc/apt/sources.list
deb http://archive.ubuntu.com/ubuntu saucy main restricted universe
deb http://archive.ubuntu.com/ubuntu saucy-updates main restricted universe
deb http://security.ubuntu.com/ubuntu saucy-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu saucy partner

The thing is I am not able to perform ping www.google.com or wget http://www.google.com

Means no connectivity.

root@webgls:/# wget http://www.google.com
--2014-08-22 04:38:18--  http://www.google.com/
Resolving www.google.com (www.google.com)...
 

 

How to resolve?

Thanks for your reply!

 

~~~ rahoolm

www.webgls.info


#10 Khevin

Khevin

    Advanced Member

  • Administrators
  • 235 posts
  • LocationMauritius

Posted 22 August 2014 - 05:23 PM

Hello there,

Edit the /etc/resolv.conf

/etc/resolv.conf

Google dns

nameserver 8.8.8.8
nameserver 8.8.4.4

Save and exit,

reboot,

Best Regards,

Undefined


Undefined/Khevin | Haphost Support Administrator

Grab Your Free VPS And Web Hosting Here!

Follow Us On Facebook Twitter Google+ LinkedIn Youtube


#11 jsandrade

jsandrade

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 13 October 2014 - 09:19 PM

Same issue here, I can't get any reply for ping by IP and can't resolve hostname:

# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
169.254.0.0     0.0.0.0         255.255.0.0     U     1002   0        0 venet0
0.0.0.0         0.0.0.0         0.0.0.0         U     0      0        0 venet0 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users